React Native — Install AdaptyUI SDK

Begin configuring the Adapty paywall builder by installing the AdaptyUI SDK. Note that the AdaptyUI SDK is necessary only if you intend to use the paywalls created with the Paywall Builder.


You currently need to have a react-native-adapty of version 2.4.7 or higher to use UI SDK.

Please consult the compatibility table below to choose the correct pair of Adapty SDK and AdaptyUI SDK.

Adapty SDK versionAdaptyUI version
2.7.0 – - 2.0.1
2.9.3 -
2.10.1 or later2.1.2


  1. Add the dependency to your project
yarn add @adapty/react-native-ui
pnpm add @adapty/react-native-ui
npm add @adapty/react-native-ui
  1. (iOS target) Install pods provided by new dependency
pod install --project-directory=ios/
  1. (iOS target) Minimal supported iOS version is 13.0, if you see an error during pod installation, find this line in your ios/Podfile and update the minimal target. Then you should be able to perform pod install successfully
-platform :ios, min_ios_version_supported
+platform :ios, 13.0