Ask a Question
Back to All

Adjust Integration is not worked

Hello Team,

This example is not worked on my code:

Adapty Version: "react-native-adapty": "^2.4.2",

import { Adjust, AdjustConfig } from "react-native-adjust";  
import { adapty } from "react-native-adapty";

var adjustConfig = new AdjustConfig(appToken, environment);

// Before submiting Adjust config...  
adjustConfig.setAttributionCallbackListener(attribution => {  
  // Make sure Adapty SDK is activated at this point  
  // You may want to lock this thread awaiting of `activate`  
  adapty.updateAttribution(attribution, "adjust");  

// ...  

And this is how I updated it worked. But I'm still not sure because in your document it shows as above.

  Adjust.getAttribution(att => {
    // console.log(att);
          'Adjust Adid': att.adid,
          'Adjust Network': att.network,
          'Adjust Campaign': att.campaign,
          'Adjust Adgroup': att.adgroup,
      .then(() => {
        console.log('attribitiion updated success');
      .catch(err => console.log(err));

Thanks for help.